Topic-icon Unable to find a version of the runtime to run this [GELÖST]

Mehr
8 Jahre 7 Monate her #18587 von Luke
Luke antwortete auf das Thema: Unable to find a version of the runtime to run this [GELÖST]
Hallo lead341

Ja mit dem Launcher war das ein Missverständniss. Ich fragte ja am 12.7 nochmal zur Sicherheit nach, ob sich der Launcher selbst starten lässt. Nachdem Du das nicht negativ beantwortet hast, ging ich davon aus das sowohl der Launcher als auch WCS startet, nur WCS nicht vom Launcher aufgerufen werden kann.

lead341 schrieb: Hi Luke,

besten Dank!
Ich konnte das Problem nach etlichen Forenrecherchen nun lösen (was würde der Laie heute ohne Internet bzw. Foren machen???). Nun, ich hatte das net framework 4.0 installiert - allerdings genügte dies nicht. Ich musste separat die Version 3.5 nachinstallieren - und plötzlich funktionierte es.


Genau in die Richtung ging dann meine Vermutung, als Du heute geschrieben hast, das der Launcher nicht startet.

Ich habe keine Ahnung, was das net framework ist, wozu man es benötigt


Das NET Framework besteht unter anderem aus Runtimes, die von NET Programmen zwingend benötigt werden. Es gibt Sprachen bei denen brauchen die compilierten Programme diese Bibliotheken zwingend um laufen zu können, während es bei anderen Sprachen keine solchen Abhängigkeiten gibt. Delphi Programme brauchen z.B. keine Runtimes, oder AI3 womit ich u.a. auch programmiere. Das "WCS Setup ZIP Check & Unzip Tool" ist z.B. damit geschrieben worden.

und weshalb in einer fortgeschrittenen Version die früheren Versionen nicht mit inbegriffen sind.


Ich programmiere selbst nicht in NET, aber ich habe einige fremde Programme die NET brauchen. Ganz exakt kann ich es Dir also nicht sagen, das könnte mit Sicherheit Keldor, aber was ich weiss ist folgendes:

Das ist a bisserl hakelig im Falle von NET Framework. Die 4.0 ist zwar abwärtskompatibel, enthält aber weder 3.5 noch 2.0. Vor allem letzteres ist noch sehr weit verbreitet. Wenn nun also ein NET Programm zwingend und explizit ein Framework 3.5 oder 2.0 anfordert und nur ein 4.0 installiert ist, kann sowas passieren wie hier. Verwirrenderweise ist in 3.5 tatsächlich auch das 2.0 enthalten, Du hast jetzt also alles was man braucht. Heutzutage sollte eh auf jedem Rechner auf jeden Fall 2.0 und 3.5 installiert sein. 4.0 brauchts dagegen nur bei Bedarf, schadet aber auch nichts wenns drauf ist. Die meisten Benutzer wissen das aber nicht, und machen das fälschlicherweise genau umgekehrt. Ich erlebe das regelmässig bei Kunden.

Aber Hauptsache es funktioniert.


Auf jeden Fall. :) Aber Details sind wichtig und vor allem die Rückmeldungen. Je mehr Rückmeldungen und je mehr Details, desto besser wird hier die Wissensdatenbank für WCS und desto schneller kann man helfen.

Ok, ich markiere das als gelöst.

Tools: Setup ZIP Check & UnZip / EPW-Bug Repair Tool / Debug-Build Support-Tool / Pilot Manager ...und andere
Projekte: Deutsch-Mod / WCS+

Bitte Anmelden oder Registrieren um der Konversation beizutretten.

Ladezeit der Seite: 0.085 Sekunden

Letzte Beiträge

    Login